Squeeze 11 for MacOS 10.10 and 10.11

Last Updated: Dec 01, 2016 12:55PM PST
The recent update to Squeeze 11 to make it compatible for MacOS 10.12 has caused some customers on MacOS 10.10 and 10.11 to have difficulty installing the new version. This is because the 10.10 and 10.11 OS's detect an issue with the file and say that it is corrupted and tell you to throw it in the trash. 



To get around this issue you can just download the previous version of Squeeze 11 (which was not compatible with MacOS 10.12).  You can download this older version here:  Squeeze 11 for MacOS 10.10 and 10.11
squeezesupport@sorensonmedia.com
http://assets3.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete